Toolkit Release Notes 2017 1.2

This Toolkit 2017 R1.2 release (Build 2017.1.2.18242) includes bug fixes.

Software Requirements

The following software is required to successfully use Toolkit.

Servers Supported

  • Windows Server 2008 R2, 2012 R2, or 2016
  • Microsoft® .NET Framework is required to use Toolkit's .NET component
    (1.1, 2.0+, or 4.5.)

Note: If this is the first time you are installing Toolkit 2017 on a Windows 2012 server, you need to download and install two Microsoft updates for Windows 2012 servers. These updates resolve issues with the Microsoft Visual C++ Redistributable Runtime Components. For links and step-by-step instructions, see this ActivePDF Knowledge Base article: Installing Toolkit 2017 on Windows 2012 Servers.

Desktops Supported

(32- or 64-bit editions)

  • Windows® 7, 8, 8.1, 10
  • Microsoft® .NET Framework is required to use Toolkit's .NET component
    (1.1, 2.0+, or 4.5.)

Hardware Requirements

The minimum hardware requirements for Toolkit are:

Server and desktop

  • 125 MB of RAM
  • 25 MB of hard disk space (for application)

Bugs Fixed

ID # Description Resolution
17396 When SetFormFieldData was called to populate form fields, a memory exception occurred causing Toolkit to fail without providing an error message. Changes to the code related to how text boxes are handled resolved this issue.
File
Specific
Multiple PDF files caused Toolkit conversions to fail. Toolkit was updated to better handle problem files.

Documentation

Installation and API information is available in the Toolkit API Reference Guide:

http://documentation.activepdf.com/Toolkit/Toolkit_API/index.htm

×