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activePDF KB #11566 - Unable to load DLL or DLL is not found
activePDF KB #11566 - Unable to load DLL or DLL is not found
Problem: Configuration Printer Version | Return to Search
Unable to load DLL or DLL is not found
 
Product Version      
Toolkit Lite
Toolkit Std
Toolkit Pro
4.0
3.8.6
 
Problem
 
Running activePDF Toolkit in .NET produces one of the following exceptions:
  • Unable to load DLL (APT40LU.DLL)
  • Unable to load DLL (APT40LE.DLL)
  • Unable to load DLL (APT40SU.DLL)
  • Unable to load DLL (APT40SDV.DLL)
  • Unable to load DLL (APT40SE.DLL)
  • Unable to load DLL (APT40PU.DLL)
  • Unable to load DLL (APT40PDV.DLL)
  • Unable to load DLL (APT40PE.DLL)
The exception might also appear as Filename.DLL is not found. In most cases, the exception does not occur until the application using Toolkit is moved to a new machine, or the .NET application was developed with the Evaluation or Developer Edition of Toolkit, and is now running under the Production Edition.
 
Cause
 
The causes for this issue are:
  • Bin DLLs missing from System32
  • Wrong edition of APToolkitNET.DLL referenced in application
  • Access denied to DLLs
 
Resolution
 

Bin DLLs missing from System32

In order to use activePDF Toolkit 4.0 in .NET, you must add the installed APToolkitNET.DLL as a reference in your .NET application. This DLL references the DLLs found in the Toolkit Bin folder, but only after they have been copied to the System32 folder per the instructions found in KB #10001. The Bin folder DLLs must correspond to the in-use Toolkit edition. For example, if the message indicates the APT40SE.DLL file, then your application references the Standard Evaluation edition and the APT40SE.DLL file is not in the system 32.

Wrong edition of APToolkitNET.DLL referenced in application

Although the name is exactly the same, each edition of Toolkit installs and requires its own unique copy of the APToolkitNET.DLL, which only work with that edition. For instance, you cannot use the Toolkit 4.0 Standard Developer Edition APToolkitNET.DLL with the Toolkit 4.0 Standard Production Edition. You will need to ensure that your .NET application is referencing the correct edition of the APToolkitNET.DLL per the instructions found in KB #10001. You will aslo need to ensure that the corresponding Bin folder DLLs are in the System32 folder. Refer to KB #11568 for information on moving an application from a Development or Evaluation environment to a Production machine.

Access denied to DLLs

It is possible, yet unlikely, that the corresponding Bin folder DLLs in the System32 folder are lacking the necessary permissions. You will need to ensure that all applicable users invoked by the application are given Full Control to the DLLs. Refer to KB #11567 for more information about applicable users.
 
Last Updated 2008-02-05 Printer Version | Return to Search
 
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